A newbie problem - Red5 0.5 works with ant server but not with red5.sh :-(

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

A newbie problem - Red5 0.5 works with ant server but not with red5.sh :-(

fgomes
Hi

I've been using RED5 from time to time in some tests (to see if we can start using it for internal videoconference), but always using the windows installer. Now I've tried to install it in linux (red5 0.5), so I run the ant server command and it compiled and started working, I manage to connect to the server from other machines, without problems. The problem I have is that if I try to run red5.sh instead of ant server, I get the following error:

[root@xpto red5-0.5]# ./red5.sh
Exception in thread "main" java.lang.NoClassDefFoundError: org/red5/server/Standalone

What am I missing? I'm using latest java release (1.5  update 9) and ANT 1.6.2. The server is a CentOS 4.4.

As an aditional note, when i do ant server the red5 starts working but ant logs many text, and starts with this:

[root@xpto red5-0.5]# ant server
/usr/bin/build-classpath: error: Could not find jaxp_parser_impl Java extension for this JVM
/usr/bin/build-classpath: error: Could not find xml-commons-apis Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found

But in the end it starts the server...

     [java] [DEBUG] 13110 main:( org.red5.server.Standalone.debug ) Startup done in: 13115 ms

Any advice would be very helpfull!

Best regards

Fernando


_______________________________________________
Red5 mailing list
[hidden email]
http://osflash.org/mailman/listinfo/red5_osflash.org