Not able to send

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Not able to send

Juan Diego
Hi
I am using red5-client to connect to wowza but I am having a problem, I need to send multiple parameters. And for some reason in my wowza server I see my app connecting but it is not invoking the correct parameters. I hope you can help me with this.  I am trying to pass an array as params.  I tried passing the array as an object in the params array but it didn't work.

Ii after connecting to my server I do this
Object[] params = { "mytextparam1", "mytextparam2"  };
client.invoke("publishPlaylist", params, new IPendingServiceCallback() {

It works, but I am burning my params in code and I have an array so the size will change according to what I need.

If I do the following everything breaks down
String test = "mytextparam1;
Object[] params2 = { test, "mytextparam2"  };
client.invoke("publishPlaylist", params2, new IPendingServiceCallback() {

I am not able to pass my params
I tried also this
Object[] params = filePathNames.toArray() ; 
And it doesnt work.

Everything seems fine from the side of the client
I get the following when I print the results
Service: null Method: publishPlaylist Num Params: 2 0: mytextparam1 1: mytextparam2





--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.