Red5 1.07 Oflademo & Demo Installer

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Red5 1.07 Oflademo & Demo Installer

Todd Leishman
I just installed Red5 1.07 on Ubuntu 14.04.  When I go to my red5 installation at 192.168.2.153:5080, I can see the link to install ready made applications.  If I click on it, the installer list is empty.  If I go ahead and click on the "Launch a Demo" link, I see the list of demos.  If I click on oflademo, it launches as normal, but if I try to connect at rtmp://192.168.2.153/oflaDemo, the Output section shows the following:

(81) Connections: true | true
(11453) connected?: true
(11505) NetConnection.onStatus: 
  description = No scope 'oflaDemo' on this server.
  code = NetConnection.Connect.Rejected
  level = error


(11505) NetConnection.onStatus: 
  level = status
  code = NetConnection.Connect.Closed

I haven't used Red5 for awhile -- since 1.0 RC2, so I'm not sure what I could be doing wrong.  Any ideas?


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Red5 1.07 Oflademo & Demo Installer

Mondain
There was a fix to the installer due to a change from googlecode to github; it may not be in the version you have. I would suggest grabbing the 1.0.8-M8 from the releases tab; try it out and let us know.


Paul

On Tue, Aug 16, 2016 at 3:22 PM Todd Leishman <[hidden email]> wrote:
I just installed Red5 1.07 on Ubuntu 14.04.  When I go to my red5 installation at 192.168.2.153:5080, I can see the link to install ready made applications.  If I click on it, the installer list is empty.  If I go ahead and click on the "Launch a Demo" link, I see the list of demos.  If I click on oflademo, it launches as normal, but if I try to connect at rtmp://192.168.2.153/oflaDemo, the Output section shows the following:

(81) Connections: true | true
(11453) connected?: true
(11505) NetConnection.onStatus: 
  description = No scope 'oflaDemo' on this server.
  code = NetConnection.Connect.Rejected
  level = error


(11505) NetConnection.onStatus: 
  level = status
  code = NetConnection.Connect.Closed

I haven't used Red5 for awhile -- since 1.0 RC2, so I'm not sure what I could be doing wrong.  Any ideas?


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Red5 1.07 Oflademo & Demo Installer

Todd Leishman
Great, thank you for the info!  I just read another string that said we should use the apps "live" and "vod" now instead of oflademo... Is that right?


On Tuesday, August 16, 2016 at 1:24:51 PM UTC-6, Mondain wrote:
There was a fix to the installer due to a change from googlecode to github; it may not be in the version you have. I would suggest grabbing the 1.0.8-M8 from the releases tab; try it out and let us know.

<a href="https://github.com/Red5/red5-server/releases/tag/v1.0.8-M8" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FRed5%2Fred5-server%2Freleases%2Ftag%2Fv1.0.8-M8\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGZ_M9Hh2Ssy8m0vf9otYFGsRfWoA&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FRed5%2Fred5-server%2Freleases%2Ftag%2Fv1.0.8-M8\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGZ_M9Hh2Ssy8m0vf9otYFGsRfWoA&#39;;return true;">https://github.com/Red5/red5-server/releases/tag/v1.0.8-M8

Paul

On Tue, Aug 16, 2016 at 3:22 PM Todd Leishman <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="cv8DrAGaCwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">todd...@...> wrote:
I just installed Red5 1.07 on Ubuntu 14.04.  When I go to my red5 installation at <a href="http://192.168.2.153:5080" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%3A5080\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFUCxuaKwnS2zmeSgpCj7qWAAm5UA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%3A5080\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFUCxuaKwnS2zmeSgpCj7qWAAm5UA&#39;;return true;">192.168.2.153:5080, I can see the link to install ready made applications.  If I click on it, the installer list is empty.  If I go ahead and click on the "Launch a Demo" link, I see the list of demos.  If I click on oflademo, it launches as normal, but if I try to connect at rtmp://<a href="http://192.168.2.153/oflaDemo" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%2FoflaDemo\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHmnZdSOU5qd_WlutwsKOFdSy3GfQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%2FoflaDemo\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHmnZdSOU5qd_WlutwsKOFdSy3GfQ&#39;;return true;">192.168.2.153/oflaDemo, the Output section shows the following:

(81) Connections: true | true
(11453) connected?: true
(11505) NetConnection.onStatus: 
  description = No scope 'oflaDemo' on this server.
  code = NetConnection.Connect.Rejected
  level = error


(11505) NetConnection.onStatus: 
  level = status
  code = NetConnection.Connect.Closed

I haven't used Red5 for awhile -- since 1.0 RC2, so I'm not sure what I could be doing wrong.  Any ideas?


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="cv8DrAGaCwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">red5interest...@googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Red5 1.07 Oflademo & Demo Installer

Rajdeep Rath

Hi

The oflaDemo application is a special  app. It provides you with a list with of vod files and a playback view. And that app is not included by default in red5.

If you are looking for setting up live streaming or video on demand playback, just use live / vod application instead. Your rtmp will be rtmp://localhost/live or rtmp://localhost/vod as per choice.

Regards
Rajdeep Rath


On Aug 17, 2016 1:21 AM, "Todd Leishman" <[hidden email]> wrote:
Great, thank you for the info!  I just read another string that said we should use the apps "live" and "vod" now instead of oflademo... Is that right?


On Tuesday, August 16, 2016 at 1:24:51 PM UTC-6, Mondain wrote:
There was a fix to the installer due to a change from googlecode to github; it may not be in the version you have. I would suggest grabbing the 1.0.8-M8 from the releases tab; try it out and let us know.


Paul

On Tue, Aug 16, 2016 at 3:22 PM Todd Leishman <[hidden email]> wrote:
I just installed Red5 1.07 on Ubuntu 14.04.  When I go to my red5 installation at 192.168.2.153:5080, I can see the link to install ready made applications.  If I click on it, the installer list is empty.  If I go ahead and click on the "Launch a Demo" link, I see the list of demos.  If I click on oflademo, it launches as normal, but if I try to connect at rtmp://192.168.2.153/oflaDemo, the Output section shows the following:

(81) Connections: true | true
(11453) connected?: true
(11505) NetConnection.onStatus: 
  description = No scope 'oflaDemo' on this server.
  code = NetConnection.Connect.Rejected
  level = error


(11505) NetConnection.onStatus: 
  level = status
  code = NetConnection.Connect.Closed

I haven't used Red5 for awhile -- since 1.0 RC2, so I'm not sure what I could be doing wrong.  Any ideas?


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Red5 1.07 Oflademo & Demo Installer

Todd Leishman
In reply to this post by Todd Leishman
Perfect, that's just what I need to do, so thank you.



On Tuesday, August 16, 2016 at 1:22:08 PM UTC-6, Todd Leishman wrote:
I just installed Red5 1.07 on Ubuntu 14.04.  When I go to my red5 installation at <a href="http://192.168.2.153:5080" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%3A5080\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFUCxuaKwnS2zmeSgpCj7qWAAm5UA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%3A5080\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFUCxuaKwnS2zmeSgpCj7qWAAm5UA&#39;;return true;">192.168.2.153:5080, I can see the link to install ready made applications.  If I click on it, the installer list is empty.  If I go ahead and click on the "Launch a Demo" link, I see the list of demos.  If I click on oflademo, it launches as normal, but if I try to connect at rtmp://<a href="http://192.168.2.153/oflaDemo" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%2FoflaDemo\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHmnZdSOU5qd_WlutwsKOFdSy3GfQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F192.168.2.153%2FoflaDemo\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHmnZdSOU5qd_WlutwsKOFdSy3GfQ&#39;;return true;">192.168.2.153/oflaDemo, the Output section shows the following:

(81) Connections: true | true
(11453) connected?: true
(11505) NetConnection.onStatus: 
  description = No scope 'oflaDemo' on this server.
  code = NetConnection.Connect.Rejected
  level = error


(11505) NetConnection.onStatus: 
  level = status
  code = NetConnection.Connect.Closed

I haven't used Red5 for awhile -- since 1.0 RC2, so I'm not sure what I could be doing wrong.  Any ideas?


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.