Server side stream playlist not working

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Server side stream playlist not working

Juan Diego
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Rajdeep Rath
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <[hidden email]> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Juan Diego
Yeah I suscribed with a client and I can only see a black screen.

On Tue, Jan 3, 2017 at 5:57 PM, Rajdeep Rath <[hidden email]> wrote:
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <[hidden email]> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Juan Diego
Hi, I kind of found something that might be the problem, but I dont know what I am doing wrong.

log.info("Corriendo2 {} tam {}  start {}", serverStream.getCurrentItem().getName(), serverStream.getCurrentItem().getLength(), serverStream.getCurrentItem().getStart());

When I do this I get this

2017-01-05 10:31:56,453 [RTMPConnectionExecutor-4] INFO  e.com.mapachedev.ramona.Application - Corriendo2 Avengers2.mp4 tam -1  start -2

I tried with Avenger2.mp4 trailer and I get the same "-1" and  "-2".  If I set a random name like mymadeupnamefile.mp4 and that file doesnt exists, it tells me that it doesnt  exists.  so it is reading from my "streams" folder but it is like it can not play the files.  I tried with flv file too.  All this my files are playable.

I am kind of lost.

On Wed, Jan 4, 2017 at 11:14 AM, Juan Diego <[hidden email]> wrote:
Yeah I suscribed with a client and I can only see a black screen.

On Tue, Jan 3, 2017 at 5:57 PM, Rajdeep Rath <[hidden email]> wrote:
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <[hidden email]> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Rajdeep Rath
Perhaps you can try a little bit more on your own. I will try to see if I can make some time and  reproduce the issue on my own.! Like I said I tried it during red5 1.0 and it was working. Haven't tried since then. 

On Thursday, January 5, 2017, Juan Diego <[hidden email]> wrote:
Hi, I kind of found something that might be the problem, but I dont know what I am doing wrong.

log.info("Corriendo2 {} tam {}  start {}", serverStream.getCurrentItem().getName(), serverStream.getCurrentItem().getLength(), serverStream.getCurrentItem().getStart());

When I do this I get this

2017-01-05 10:31:56,453 [RTMPConnectionExecutor-4] INFO  e.com.mapachedev.ramona.Application - Corriendo2 Avengers2.mp4 tam -1  start -2

I tried with Avenger2.mp4 trailer and I get the same "-1" and  "-2".  If I set a random name like mymadeupnamefile.mp4 and that file doesnt exists, it tells me that it doesnt  exists.  so it is reading from my "streams" folder but it is like it can not play the files.  I tried with flv file too.  All this my files are playable.

I am kind of lost.

On Wed, Jan 4, 2017 at 11:14 AM, Juan Diego <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;juandiego83@gmail.com&#39;);" target="_blank">juandiego83@...> wrote:
Yeah I suscribed with a client and I can only see a black screen.

On Tue, Jan 3, 2017 at 5:57 PM, Rajdeep Rath <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;rajdeeprath@gmail.com&#39;);" target="_blank">rajdeeprath@...> wrote:
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;juandiego83@gmail.com&#39;);" target="_blank">juandiego83@...> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;red5interest%2Bunsubscribe@googlegroups.com&#39;);" target="_blank">red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;red5interest%2Bunsubscribe@googlegroups.com&#39;);" target="_blank">red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;red5interest%2Bunsubscribe@googlegroups.com&#39;);" target="_blank">red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Juan Diego
Have you had any chance in testing this?

On Thu, Jan 5, 2017 at 11:13 AM, Rajdeep Rath <[hidden email]> wrote:
Perhaps you can try a little bit more on your own. I will try to see if I can make some time and  reproduce the issue on my own.! Like I said I tried it during red5 1.0 and it was working. Haven't tried since then. 


On Thursday, January 5, 2017, Juan Diego <[hidden email]> wrote:
Hi, I kind of found something that might be the problem, but I dont know what I am doing wrong.

log.info("Corriendo2 {} tam {}  start {}", serverStream.getCurrentItem().getName(), serverStream.getCurrentItem().getLength(), serverStream.getCurrentItem().getStart());

When I do this I get this

2017-01-05 10:31:56,453 [RTMPConnectionExecutor-4] INFO  e.com.mapachedev.ramona.Application - Corriendo2 Avengers2.mp4 tam -1  start -2

I tried with Avenger2.mp4 trailer and I get the same "-1" and  "-2".  If I set a random name like mymadeupnamefile.mp4 and that file doesnt exists, it tells me that it doesnt  exists.  so it is reading from my "streams" folder but it is like it can not play the files.  I tried with flv file too.  All this my files are playable.

I am kind of lost.

On Wed, Jan 4, 2017 at 11:14 AM, Juan Diego <[hidden email]> wrote:
Yeah I suscribed with a client and I can only see a black screen.

On Tue, Jan 3, 2017 at 5:57 PM, Rajdeep Rath <[hidden email]> wrote:
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <[hidden email]> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Rajdeep Rath
Hi

There is a good chance that is a bug. I would request you to try some more and then place a bug report on GitHub.

I remember the earlier usage of the API was to create a new SimplePlayItem() object and set its name to the media name. The new API using a builder pattern instead. I haven't been able to get it working either.

Regards
Rajdeep Rath

On Jan 9, 2017 9:59 PM, "Juan Diego" <[hidden email]> wrote:
Have you had any chance in testing this?

On Thu, Jan 5, 2017 at 11:13 AM, Rajdeep Rath <[hidden email]> wrote:
Perhaps you can try a little bit more on your own. I will try to see if I can make some time and  reproduce the issue on my own.! Like I said I tried it during red5 1.0 and it was working. Haven't tried since then. 


On Thursday, January 5, 2017, Juan Diego <[hidden email]> wrote:
Hi, I kind of found something that might be the problem, but I dont know what I am doing wrong.

log.info("Corriendo2 {} tam {}  start {}", serverStream.getCurrentItem().getName(), serverStream.getCurrentItem().getLength(), serverStream.getCurrentItem().getStart());

When I do this I get this

2017-01-05 10:31:56,453 [RTMPConnectionExecutor-4] INFO  e.com.mapachedev.ramona.Application - Corriendo2 Avengers2.mp4 tam -1  start -2

I tried with Avenger2.mp4 trailer and I get the same "-1" and  "-2".  If I set a random name like mymadeupnamefile.mp4 and that file doesnt exists, it tells me that it doesnt  exists.  so it is reading from my "streams" folder but it is like it can not play the files.  I tried with flv file too.  All this my files are playable.

I am kind of lost.

On Wed, Jan 4, 2017 at 11:14 AM, Juan Diego <[hidden email]> wrote:
Yeah I suscribed with a client and I can only see a black screen.

On Tue, Jan 3, 2017 at 5:57 PM, Rajdeep Rath <[hidden email]> wrote:
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <[hidden email]> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Juan Diego
which version of red5 server and red5 libraries you tried this on?

On Tue, Jan 10, 2017 at 1:34 AM, Rajdeep Rath <[hidden email]> wrote:
Hi

There is a good chance that is a bug. I would request you to try some more and then place a bug report on GitHub.

I remember the earlier usage of the API was to create a new SimplePlayItem() object and set its name to the media name. The new API using a builder pattern instead. I haven't been able to get it working either.

Regards
Rajdeep Rath

On Jan 9, 2017 9:59 PM, "Juan Diego" <[hidden email]> wrote:
Have you had any chance in testing this?

On Thu, Jan 5, 2017 at 11:13 AM, Rajdeep Rath <[hidden email]> wrote:
Perhaps you can try a little bit more on your own. I will try to see if I can make some time and  reproduce the issue on my own.! Like I said I tried it during red5 1.0 and it was working. Haven't tried since then. 


On Thursday, January 5, 2017, Juan Diego <[hidden email]> wrote:
Hi, I kind of found something that might be the problem, but I dont know what I am doing wrong.

log.info("Corriendo2 {} tam {}  start {}", serverStream.getCurrentItem().getName(), serverStream.getCurrentItem().getLength(), serverStream.getCurrentItem().getStart());

When I do this I get this

2017-01-05 10:31:56,453 [RTMPConnectionExecutor-4] INFO  e.com.mapachedev.ramona.Application - Corriendo2 Avengers2.mp4 tam -1  start -2

I tried with Avenger2.mp4 trailer and I get the same "-1" and  "-2".  If I set a random name like mymadeupnamefile.mp4 and that file doesnt exists, it tells me that it doesnt  exists.  so it is reading from my "streams" folder but it is like it can not play the files.  I tried with flv file too.  All this my files are playable.

I am kind of lost.

On Wed, Jan 4, 2017 at 11:14 AM, Juan Diego <[hidden email]> wrote:
Yeah I suscribed with a client and I can only see a black screen.

On Tue, Jan 3, 2017 at 5:57 PM, Rajdeep Rath <[hidden email]> wrote:
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <[hidden email]> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Server side stream playlist not working

Juan Diego
https://github.com/Red5/red5-server/issues/70 I think this might be related

On Wed, Jan 11, 2017 at 1:05 PM, Juan Diego <[hidden email]> wrote:
which version of red5 server and red5 libraries you tried this on?

On Tue, Jan 10, 2017 at 1:34 AM, Rajdeep Rath <[hidden email]> wrote:
Hi

There is a good chance that is a bug. I would request you to try some more and then place a bug report on GitHub.

I remember the earlier usage of the API was to create a new SimplePlayItem() object and set its name to the media name. The new API using a builder pattern instead. I haven't been able to get it working either.

Regards
Rajdeep Rath

On Jan 9, 2017 9:59 PM, "Juan Diego" <[hidden email]> wrote:
Have you had any chance in testing this?

On Thu, Jan 5, 2017 at 11:13 AM, Rajdeep Rath <[hidden email]> wrote:
Perhaps you can try a little bit more on your own. I will try to see if I can make some time and  reproduce the issue on my own.! Like I said I tried it during red5 1.0 and it was working. Haven't tried since then. 


On Thursday, January 5, 2017, Juan Diego <[hidden email]> wrote:
Hi, I kind of found something that might be the problem, but I dont know what I am doing wrong.

log.info("Corriendo2 {} tam {}  start {}", serverStream.getCurrentItem().getName(), serverStream.getCurrentItem().getLength(), serverStream.getCurrentItem().getStart());

When I do this I get this

2017-01-05 10:31:56,453 [RTMPConnectionExecutor-4] INFO  e.com.mapachedev.ramona.Application - Corriendo2 Avengers2.mp4 tam -1  start -2

I tried with Avenger2.mp4 trailer and I get the same "-1" and  "-2".  If I set a random name like mymadeupnamefile.mp4 and that file doesnt exists, it tells me that it doesnt  exists.  so it is reading from my "streams" folder but it is like it can not play the files.  I tried with flv file too.  All this my files are playable.

I am kind of lost.

On Wed, Jan 4, 2017 at 11:14 AM, Juan Diego <[hidden email]> wrote:
Yeah I suscribed with a client and I can only see a black screen.

On Tue, Jan 3, 2017 at 5:57 PM, Rajdeep Rath <[hidden email]> wrote:
I haven't worked on this (yet) but the code looks fine. I don't see your logs saying an error. I could be wrong. I have tried this long time ago. How do you know there is a problem ? Did you try subscribing to the stream from client ?

Regards 
Rajdeep Rath

On Jan 4, 2017 4:23 AM, "Juan Diego" <[hidden email]> wrote:
Hi

I am trying to create a playlist from the server side, this is what I am doing

serverStream = StreamUtils.createServerStream(scope, "testplaylist");
       
        SimplePlayItem item2 = SimplePlayItem.build("dvv.flv");
        serverStream.addItem(item2):
       
        String pelicula = "Avengers2.mp4";
        SimplePlayItem item = SimplePlayItem.build(pelicula);
        serverStream.addItem(item);
       
        serverStream.start();

When I list the stream on the server side I do see a testplaylist

This is the only thing on the logs on red5

[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=1, samplesPerChunk=2, sampleDescriptionIndex=1}
[INFO] [RTMPConnectionExecutor-4] org.red5.io.mp4.impl.MP4Reader - Entry: Entry{firstChunk=2, samplesPerChunk=1, sampleDescriptionIndex=1}

In my app logs I see this


2017-01-03 17:47:14,107 [RTMPConnectionExecutor-3] DEBUG e.com.mapachedev.ramona.Application - appJoin: Client: 6 >> Scope [name=ramona, path=/default, type=APPLICATION, autoStart=true, creationTime=1483483525521, depth=1, enabled=true, running=true]
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-1] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182
2017-01-03 17:47:14,143 [Red5_Scheduler_Worker-2] INFO  e.com.mapachedev.ramona.Application - W3C x-category:stream x-event:play c-ip:0:0:0:0:0:0:0:1 x-sname:981b04c1-3c98-4f45-a221-f31c1a70a182 x-name:testplaylist

Is there a way to know what I am i doing wrong, am I missing something?






--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to red5interest+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.


--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.