Using JW player in red5 Client not working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Using JW player in red5 Client not working

Asmita Guragain
I am trying for live streaming. I connected streaming through OBS.OBS is connected succesfully to server and in 192.168.0.108/demos/publisher.html like this.

i have used url like rtmp://192.168.0.108/live
Now i am making client side by using JWplayer. 
my setup is look like this for client side is:
'file': "rtmp://192.168.0.108/live/test",
  'image': "preview.jpg",
                  'width': '500', 'height': '400',
                  'controlbar': 'bottom',
                  'dock': 'false',
                 'provider':'rtmp',
                 'streamer':'rtmp://192.168.0.108/live',
                  'modes': [
                      {type: 'flash', src: 'jwplayer/jwplayer.flash.swf'},
                      }
                  ]

remaining portion is not included. When i replace file for local it works but while for streaming it says flash plugin failed to load.Is my file url is correct ?HOw to solve this issue. DO i have to connect in 192.168.0.108/demos/ofla_demo.html? How to connect it?
Thanks in advance

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Using JW player in red5 Client not working

Rajdeep Rath

If you have a stream called test broadcasting to the live app then your rtmp will be of rtmp://host/live/test format in jwplayer. So it should work fine. Mat be something else is wrong like..

1. Since you are using a  lan ip make sure port 1935 is open and accessible

2. Always check with localhost first.if that works but ip does not then it's a networking thing.

Your screenshot of publisher does not show any playback happening buy the logs says about publishing. So it confusing to say what is your order of executions.


On Sep 12, 2016 11:51 AM, "Asmita Guragain" <[hidden email]> wrote:
I am trying for live streaming. I connected streaming through OBS.OBS is connected succesfully to server and in 192.168.0.108/demos/publisher.html like this.

i have used url like rtmp://192.168.0.108/live
Now i am making client side by using JWplayer. 
my setup is look like this for client side is:
'file': "rtmp://192.168.0.108/live/test",
  'image': "preview.jpg",
                  'width': '500', 'height': '400',
                  'controlbar': 'bottom',
                  'dock': 'false',
                 'provider':'rtmp',
                 'streamer':'rtmp://192.168.0.108/live',
                  'modes': [
                      {type: 'flash', src: 'jwplayer/jwplayer.flash.swf'},
                      }
                  ]

remaining portion is not included. When i replace file for local it works but while for streaming it says flash plugin failed to load.Is my file url is correct ?HOw to solve this issue. DO i have to connect in 192.168.0.108/demos/ofla_demo.html? How to connect it?
Thanks in advance

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "red5" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.