diplom work -> version

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

diplom work -> version

Jacques Pütz-2

 

Thanks for your answer but my version seems to be ok.

 

D:\Red5\webapps\jacques>java -version

java version "1.5.0_08"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)

Java HotSpot(TM) Client VM (build 1.5.0_08-b03, mixed mode, sharing)

 

Hope someone else has a tip ;)

 

Jacques

 

 

> Hi

 

> Last line:

 

> 'class file has wrong version 49.0, should be 48.0'

 

> Could mean you're using a java version other than 1.5 (required for red5 to work)

 

> To get your java version Type on command line:

 

> java -version

 

> Jacques Putz escribió:

>> 

>> Hi,

>> 

>> I’ve just started my Diploma Final Work for my Master of Informatics

>> in Germany.

>> 

>> My Topic is: a Flash Based Audio / Video Jabber Messenger. I read a

>> lot about the Red5 Project.

>> 

>> It’s phantastic, so I choose to develop my audio / video component

>> using RED 5 ;).

>> 

>> I have a Problem with my first application:

>> 

>> package org.red5.server.webapps;

>> 

>> import org.red5.server.adapter.*;

>> 

>> public class jacques extends ApplicationAdapter {

>> 

>> public int add(int a, int b){

>> 

>> return (a + b);

>> 

>> }

>> 

>> }

>> 

>> I took it from the tutorial

>> http://www.joachim-bauch.de/tutorials/red5/HOWTO-NewApplications.txt

>> 

>> I get a strange error about versions :

>> 

>> D:\Red5\webapps\jacques>javac -classpath D:\Red5\lib\red5.jar

>> jacques.java

>> 

>> jacques.java:4: cannot access

>> org.red5.server.adapter.ApplicationAdapter

>> 

>> bad class file:

>> D:\Red5\lib\red5.jar(org/red5/server/adapter/ApplicationAdapter.

>> 

>> class)

>> 

>> class file has wrong version 49.0, should be 48.0

>> 

 

 

 


_______________________________________________
Red5 mailing list
[hidden email]
http://osflash.org/mailman/listinfo/red5_osflash.org
Reply | Threaded
Open this post in threaded view
|

Re: diplom work -> version

Manuel Raña
If you have several java JDK's/JRE's installed you could be running java
1.5 but compiling with JDK 1.4
Try javac -version
(not java -version)

Jacques Putz escribió:

>
> >> I get a strange error about versions :
>
> >>
>
> >> D:\Red5\webapps\jacques>javac -classpath D:\Red5\lib\red5.jar
>
> >> jacques.java
>
> >>
>
> >> jacques.java:4: cannot access
>
> >> org.red5.server.adapter.ApplicationAdapter
>
> >>
>
> >> bad class file:
>
> >> D:\Red5\lib\red5.jar(org/red5/server/adapter/ApplicationAdapter. class)
>
> >>
>
> >> class file has wrong version 49.0, should be 48.0
>
>  
>


_______________________________________________
Red5 mailing list
[hidden email]
http://osflash.org/mailman/listinfo/red5_osflash.org
Reply | Threaded
Open this post in threaded view
|

Re: diplom work -> version

Michael Plehm
Or maybe you should use the SUN JDK, not just JRE.

And by the way, a Diplomarbeit in German is thesis in English ;-)

Michael

Manolo R.G. schrieb:

> If you have several java JDK's/JRE's installed you could be running java
> 1.5 but compiling with JDK 1.4
> Try javac -version
> (not java -version)
>
> Jacques Putz escribió:
>>>> I get a strange error about versions :
>>>> D:\Red5\webapps\jacques>javac -classpath D:\Red5\lib\red5.jar
>>>> jacques.java
>>>> jacques.java:4: cannot access
>>>> org.red5.server.adapter.ApplicationAdapter
>>>> bad class file:
>>>> D:\Red5\lib\red5.jar(org/red5/server/adapter/ApplicationAdapter. class)
>>>> class file has wrong version 49.0, should be 48.0
>>  
>>
>
>
> _______________________________________________
> Red5 mailing list
> [hidden email]
> http://osflash.org/mailman/listinfo/red5_osflash.org

_______________________________________________
Red5 mailing list
[hidden email]
http://osflash.org/mailman/listinfo/red5_osflash.org
Reply | Threaded
Open this post in threaded view
|

Re: diplom work -> version

Rhys Parry
In reply to this post by Jacques Pütz-2
You are running in a jdk 1.4 and the source file is in 1.5.  If you are using windows, it is not uncommon to have issues with regards to java_home.  Even without java_home set there can be regestry entries for java that give weird behaviour.  Your safest bet is to call the 1.5 bin with javac and then the java command on that bin using :
c:>c:\jdk15_home/bin/javac << rest of path >>
c:>c:\jdk15_home/bin/java << rest of path >>

Hope this helps,
Rhys

-----Original Message-----
From: [hidden email] [mailto:[hidden email]]On
Behalf Of Manolo R.G.
Sent: October 19, 2006 7:10 AM
To: [hidden email]
Subject: Re: [Red5] diplom work -> version


If you have several java JDK's/JRE's installed you could be running java
1.5 but compiling with JDK 1.4
Try javac -version
(not java -version)

Jacques Putz escribió:

>
> >> I get a strange error about versions :
>
> >>
>
> >> D:\Red5\webapps\jacques>javac -classpath D:\Red5\lib\red5.jar
>
> >> jacques.java
>
> >>
>
> >> jacques.java:4: cannot access
>
> >> org.red5.server.adapter.ApplicationAdapter
>
> >>
>
> >> bad class file:
>
> >> D:\Red5\lib\red5.jar(org/red5/server/adapter/ApplicationAdapter. class)
>
> >>
>
> >> class file has wrong version 49.0, should be 48.0
>
>  
>


_______________________________________________
Red5 mailing list
[hidden email]
http://osflash.org/mailman/listinfo/red5_osflash.org

_______________________________________________
Red5 mailing list
[hidden email]
http://osflash.org/mailman/listinfo/red5_osflash.org